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Programy w LabVIEW moga by¢ organizowane w projekty, zawierajace pliki
konieczne do ich dziatania (pliki kodu, biblioteki, niestandardowe kontrolki, pliki
tekstowe, pliki graficzne, etc.). W ramach projektu pliki te moga zostaé
posegregowane w folderach. Podstawowym narzedziem shuzacym do obstugi
zawarto$ci projektu jest Project Explorer, ktérego okno pojawia si¢ w momencie
otwarcia/stworzenia projektu. Zawarto$¢ projektu mozna przegladaé jako liste jego
elementow lub jako liste plikow na dysku komputera.




Foldery w projekcie

+ 0J Project Documentation
+ J Type Definitions

Virtual folders

Organizuja pliki w
folderach w
projekcie
Sa niezalezne od
lokalizacji plikow na
dysku

+ [@ subVis
#[@ controls

Autopopulating
folders

tacza folder w
projekcie z folderem
na dysku

Automatycznie
uaktualniaja liste
plikow zawartych w
folderach
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Istnieja dwa glowne typy folderow, jakie dostepne sa w projektach w LabVIEW:
wirtualne (Virtual Folders) oraz uzupelniajace si¢ automatycznie (Autopopulating

Folders).

Aby doda¢ folder wirtualny nalezy klikng¢ prawym przyciskiem myszy na poziom w
ktorym chcemy go stworzy¢ i wybraé New>Virtual Folder. Aby doda¢ pliki do
takiego folderu nalezy klikng¢ na niego prawym przyciskiem myszy i wybraé
Add>File. Mozna takze stworzy¢ folder i jednoczesnie (jednorazowo) automatycznie
doda¢ jego zawarto$¢ - klikngé prawym przyciskiem myszy na poziom w ktorym

chcemy go stworzy¢ i wybraé Add>Folder (Snapshot)....

Aby stworzy¢ folder typu Autopopulating, nalezy kliknag¢é prawym przyciskiem
myszy na poziom w ktorym chcemy go stworzy¢é i wybraé Add>Folder

(Autopopulating)....
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x Documentation
Pozwala tworzy¢ opis programu,
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Aby wyswietli¢ okno wtasnosci programu (VI Properties), nalezy wybra¢ File>VI
Properties.




Zasady projektowania Front Panelu

Front
Panel

powinien... Udostepniac
tylko te
funkcje, ktére
sq dostepne

Byc¢ czytelny
dla
uzytkownika

By¢
Byc zorganizowany
funkcjonalny i
uporzadkowany
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Zasady projektowania Front Panelu
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Przyktady dobrze i Zle zaprojektowanych Front Paneli.



Zasady projektowania Block Diagramu

Block
Dla.gr.am Zawierac tylko
Byc¢ czytelny powimen... elementy
dla potrzebne do
uzytkownika dziatania
programu
) ) Posiadac
Byc roz{ozony dokumentacije,
w logiczny i opisujaca
funkcjonalny dziatanie
sposob fragmentow
kodu
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Block Diagram ,,Spaghetti”

=

o
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Przyktad Zle zaprojektowanego Block Diagramu.
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Etykiety (Label)
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Funkcja

Reszta z dzielenia
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Do opisywania Block Diagramu oraz Front Panelu mozna wykorzysta¢ etykiety. Aby
doda¢ swobodng etykiete¢ nalezy dwukrotnie klikng¢ lewym przyciskiem myszy w
wolnym miejscu. Swobodne etykiety moga zosta¢ zaczepione do elementow Block
Diagramu przez potaczenie ich strzatka, pojawiajaca si¢ po najechaniu kursorem na
etykiete. Mozliwe jest takze stworzenie etykiet poddiagraméw w strukturach — aby to
zrobié, nalezy klikna¢ prawym przyciskiem myszy na dang strukture i wybra¢ Visible

Items>Subdiagram Label.




Wycinki kodu (Snippet)

Spowolnienie petli
250 2 E
’ T True 't ]
Stopnie
Kat
: 120 |> |- F
E Jednostka I
e [
1. Zaznacz
i
: : : @]
2. Edit>Create VI Snippet from Selection | ‘ True ~ |
Stopnie
\ ‘Kat

=P || fizsiy

180 |> |>

‘Jednostka

=
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Pomocne w dokumentacji kodu (np. na forach internetowych) bywaja tzw. wycinki
kodu (Snippet). Wycinek taki jest graficzng reprezentacja fragmentu Block
Diagramu, zapisang w formacie PNG. W metadanych tego pliku graficznego
zapisywany jest caty kod reprezentowany przez wycinek, co pozwala na proste
uruchomienie go w srodowisku LabVIEW.

Aby stworzy¢ wycinek nalezy zaznaczy¢ wybrany fragment kodu i wybraé
Edit>Create VI Snippet from Selection, po czym nalezy go zapisa¢. Zapisanego
wycinka nie mozna edytowa¢ w innych programach graficznych, gdyz usuwajg one
zawarty w metadanych kod.

Aby umiesci¢ wycinek na Block Diagramie, wystarczy przeciggna¢ na niego plik z
wycinkiem (w przypadku gdy wycinek pochodzi z Internetu, nalezy go najpierw
zapisa¢ na komputerze).
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Debuging

Ztamana strzatka oznacza btad

/ kompilacji.
* Error list - O X

Items with errors
LPM s

v
2 errors and wamnings Show Warnings [
# Block Diagram Errors ~
. , Tunnel: Missing assignment to tunnel
Lista b’(edOW /‘ ¥ou have connected two terminals of different types.

uniemozliwiajacych
kompilacje programu.

Details
The Case or Event structure does not have anything wired to the output tunnel in one or more cases, Since only &
one frame of the structure is executed, every frame must assign values to all the outputs. Right-click the tunnel

and select Use Default If Unwired to relax this requirement.

Szczegoty na dotyczace /
zaznaczonego btedu. .
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Btedy kompilacji sygnalizowane sg ztamang strzatka uruchamiania programu. Po jej
kliknigciu uzyskuje si¢ dostep do listy btedow, ktére uniemozliwiajg kompilacje i ich
szczegotowych opisow.




Debuging

Czeste przyczyny btedu kompilacji:

a) .
15]------- : b) C) d) )
,: String Numeric W False b N
MNumeric ”‘ '%* - - {p[iz3
g --- -2
| o ]
9)
[L00HN x"2
[ — | E MNumeric Pytanie 1

Dlaczego program nie
kompiluje w kazdym z
przypadkow?
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Narzedzia do debugowania

Y e Wykonywanie programu jest spowolnione, a przeptywajace dane
=) sg podswietlane - pozwala to na kontrole przeptywu danych

Wykonywanie Vi krok po kroku, pozwala na kontrole dziatania
o IE. =) poszczegolnych weztow

— Prébkowanie pozwala na podgladanie wartosci przeptywajacych
E:H— w drutach
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Indykator numeryczny

Moze wyswietla¢ wiele wykresow

Na osi x kolejne probki

Wykorzystywany do prezentacji danych

»W czasie rzeczywistym”

Wykres typu Waveform Chart

Waveform Chart
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Wykres typu Waveform Graph

Indykator numeryczny

1-

Moze wyswietlaé wiele wykresow o
statym probkowaniu

1 [ [ [ ! ! [ [ ! !
. . , . 0 25 50 75 100 125 150 175 200 225
Na osi x kolejne probki x

Wykorzystywany do prezentacji

wczesniej wykreowanych danych Sprawdz tez: Przykiad |
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(sin [V

C
Waveform Graph == - J
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https://kaim.wppt.pwr.edu.pl/files/LabVIEW/LabVIEW_4_Przykład_1.vi

Chart vs Graph
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Waveform Graph oczekuje gotowego zestawu danych w postaci tablicy 1D. Aby
wyswietli¢ wiele sygnatow na jednym wykresie, nalezy ztaczy¢ je w tablice 2D.

Waveform Chart oczekuje w kazdym okresie petli jednego punktu (jednej wartos$ci).
Aby wyswietli¢ kilka sygnatéw na jednym wykresie, nalezy zebra¢ je w klaster.
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Wykres typu Graph XY

XY Graph | Plato /\/‘
p = =
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Wykres typu XY Graph oczekuje klastra zlozonego z tablicy 1D wspotrzednych X
oraz tablicy 1D wspotrzednych Y. Aby wyswietli¢ wiele sygnatéw na takim
wykresie, nalezy zebra¢ klastry w tablice.




Property Node
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Create Control
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Property Node pozwala na programowe zmienianie i odczytywanie wiasno$ci
indykatoréw 1 kontrolek (np.: polozenie, kolor, zakresy wprowadzanych danych,
warto$¢ elementu). Uwaga: nie wszystkie wlasno$ci moga by¢ zmieniane po
skompilowaniu programu, nie mozna ich takze zmienia¢ programowo (przyktad:
nazwy elementéw w kontrolce wyliczeniowej Enum).

Aby stworzy¢ Property Node nalezy klikng¢ prawym przyciskiem myszy na
kontrolkg/indykator i wybraé Create>Property Node, a nastgpnie wskazaé wlasnos¢,
ktorej ma dotyczy¢. Jeden Property Node moze dawac dostep do wigcej niz jednej
wlasnosci (graficzne rozciggnigcie lub PPM>Add Element). Jesli korzysta si¢ z
dostepu do wielu wilasnosci w ramach jednego Property Node, wpisywanie/
odczytywanie odbywa si¢ kolejno z gory na doét.

Aby przetaczyé wlasno$¢ pomigdzy trybem odczytywania i wpisywania nalezy
klikng¢ na nig prawym przyciskiem myszy i wybra¢ Change To Read/Write.
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/mienne Lokalnhe

Waveform Chart
=

Create Constant
Create Control
Create Indicator

Visible ltems >
Find Indicator
Make Type Def.

Hide Indicator
Change to Control
Change to Censtant
Description and Tip..

Cluster, Class, & Variant Palette )

+ View As lcon
JKI Design Palette

Properties

Create Constant
Create Control
Create Indicator

Visible lterms »

Find >
Select ltem »

Change To Write

Help
Description and Tip...
Breakpoint

Boolean Palette
Create

v v v v

Replace
Open Front Panel

JKI Design Palette
Remove and Rewire

Constant
Centrol

Indicator

Local Variable

Reference

Property Node »
Invoke Node »
Channel Writer...

Cluster from Selection
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Zmienne lokalne pozwalaja uzyska¢ dostgp do kontrolki lub indykatora w wielu

miejscach na Block Diagramie.

Aby stworzy¢ zmienng lokalng nalezy klikngé prawym przyciskiem myszy na

kontrolke/indykator i wybra¢ Create>Local Variable.

Mozliwe jest przetaczanie trybu dziatania zmiennej z wpisywania na odczytywanie
warto$ci, w tym celu nalezy klikng¢ na nig prawym przyciskiem myszy i wybraé

Change To Read/Write.
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/mienne Lokalnhe

Boolean "

LA™ -y,

=fe]
TF |

stop

100
[N,

Nalezy uwazaé, aby nie nadpisywa¢ zmiennych lokalnych w dwodch miejscach
programu, a w szczego6lnosci by nie robi¢ tego jednocze$nie. W przypadku takim nie
ma pewnosci ktore nadpisanie wykona si¢ pierwsze, przez co program moze dziataé
w nieoczekiwany i niestabilny sposob.

W
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Dioda w pokazanym powyzej przyktadzie miga¢ bgdzie w losowy sposob.



Zadanie 1

Pobierz program ze strony www.

Zlokalizuje btedy w programie. Napraw je. Oznacz
naprawione btedy etykietami na Block

Diagramie albo Front Panelu.

Color Box Constant

Use the color box constant to
| supply a constant color value to
4 the block diagram.

Wskazowka: typ Detailed help y
danych Color Box G >
Constant

@ Politechnika Wroctawska
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https://kaim.wppt.pwr.edu.pl/files/LabVIEW/LabVIEW_4_Zadanie_1.vi

Zadanie 2

Zaprojektuj etykiete nagtowkowa, zawierajgcg miejsce na:
e nazwe programu lub funkcji,

e dane autora,

e numer wersji kodu oraz date stworzenia,

e opis funkcjonalnosci.

Zapisz etykiete jako wycinek (snippet).
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Zadanie 3

Napisz program do rysowania prostej zadanej przez
wspotczynnik kierunkowy oraz wyraz wolny.
Podpowiedz: do utworzenia tablic wykorzystaj petle For
oraz Auto-indexing.

]ﬁg Politechnika Wroctawska
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Zadanie 4

Napisz program do symulacji sygnatu sinusoidalnego,
ktory bedzie wyswietlany na wykresie typu Waveform
Chart. Wykorzystaj Property Nodes kontrolki Waveform
Chart, aby umozliwi¢ uzytkownikowi zmiane koloru tta,
wykresu, siatki. (Podpowiedz: wykorzystaj kontrolke
Color box).

]% Politechnika Wroctawska
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Zadanie 5

Napisz program symulujacy prace sygnalizatora
drogowego.

J
J
J
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Zadanie 6

Na wykresie typu Graph XY narysuj okrgg o zadanym
przez uzytkownika promieniu.
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Zadanie 7

Napisz program do tworzenia krzywych Lissajous.
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